Announcement

Collapse
No announcement yet.

ISQ not being called in document XML

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • ISQ not being called in document XML

    Hi,
    We want to attach a document by EDI using <Document> XML.
    As you can see I have a <IntSavedQuery> to retrieve the order_release_gid.
    When we upload this XML, there was no error but the owner_object_gid is NULL in the document table.
    Therefore, it seems to be not calling the ISQ.

    Note: The value for my <DocContentBinary> is replaced with "JV12345" for simplicity.

    Below is my code snippet:

    <GLogXMLElement>
    <Document xmlns="http://xmlns.oracle.com/apps/otm">
    <DocumentGid>
    <Gid>
    <DomainName>AGCO</DomainName>
    <Xid>HL1238</Xid>
    </Gid>
    </DocumentGid>
    <TransactionCode>I</TransactionCode>
    <DocumentOwner>
    <DataQueryTypeGid>
    <Gid>
    <Xid>ORDER RELEASE</Xid>
    </Gid>
    </DataQueryTypeGid>

    <ObjectGid>
    <IntSavedQuery>
    <IntSavedQueryGid>
    <Gid>
    <DomainName>AGCO</DomainName>
    <Xid>AGCO_CHECK_ORDER_RELEASE_GID</Xid>
    </Gid>
    </IntSavedQueryGid>
    <IntSavedQueryArg>
    <ArgName>OB_GID</ArgName>
    <ArgValue>AGCO.DAS00077370-01</ArgValue>
    </IntSavedQueryArg>
    </IntSavedQuery>
    <Gid>
    <DomainName>AGCO</DomainName>
    <Xid/>
    </Gid>
    </ObjectGid>
    </DocumentOwner>
    <DocumentContent>
    <DocMimeType>application/pdf</DocMimeType>
    <DocContentBinary>JV12345</DocContentBinary>
    </DocumentContent>
    </Document>
    </GLogXMLElement>
    </TransmissionBody>

  • #2
    Are you trying to upload an attachment by what EDI?
    Thanks,
    Vinoth Gopalakrishnan
    http://www.vinoth.co/
    Reach out for OTM/GTM - Transportation/Logistics and Blockchain Consultations/Strategy

    Comment

    Working...
    X