Announcement

Collapse
No announcement yet.

[SOLVED] Exception during Order Release

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] Exception during Order Release

    Hi

    I am not sure if this is the right topic to post this but will try nonetheless.

    I encountered an error in my production environment where an order release failed with the following error:

    weblogic.jdbc.extensions.PoolLimitSQLException: weblogic.common.resourcepool.ResourceLimitExceptio n: No resources currently available in pool PRIMARY_JTS to allocate to applications, please increase the size of the pool and retry..

    Has anyone encountered this problem before?

    My PRIMARY_JTS config is as follows:
    Initial Capacity= 5, Initialise at STATIC
    Maximum Capacity=30, Refresh when BOTH, every 1 min
    Capacity Increment=2, Shrint at LRU, every 5 min

    Whats causing this error, and is my config correct?

    Thanks!

  • #2
    Ian,

    The error indicates that you've exceeded the capacity of the primary OTM DB pool (PRIMARY_JTS). The default size is to start at 100 connections and grow up to 150.

    In order to resolve this:
    1. First ensure that your Oracle DB is configured to allow enough connections (the PROCESSES setting). I'd recommend a value of at least 300.
    2. Then, login to OTM as DBA.ADMIN
    3. Navigate to: Configuration and Administration > System Administration > Data Source Manager
    4. Run an open search and then edit the PRIMARY_JTS entry
    5. Click on the Pool tab
    6. Update the Maximum Capacity field. The default is 150 and you should be fine bumping it up to 200.
    7. Click Finished to save.
    I don't remember if this setting is dynamic, but I'd bounce OTM, just to be safe.

    That's it! Please update the post if this resolves your issue.

    Hope this helps!
    --Chris

    Comment


    • #3
      Originally posted by chrisplough View Post
      Ian,

      The error indicates that you've exceeded the capacity of the primary OTM DB pool (PRIMARY_JTS). The default size is to start at 100 connections and grow up to 150.

      In order to resolve this:
      1. First ensure that your Oracle DB is configured to allow enough connections (the PROCESSES setting). I'd recommend a value of at least 300.
      2. Then, login to OTM as DBA.ADMIN
      3. Navigate to: Configuration and Administration > System Administration > Data Source Manager
      4. Run an open search and then edit the PRIMARY_JTS entry
      5. Click on the Pool tab
      6. Update the Maximum Capacity field. The default is 150 and you should be fine bumping it up to 200.
      7. Click Finished to save.
      I don't remember if this setting is dynamic, but I'd bounce OTM, just to be safe.

      That's it! Please update the post if this resolves your issue.

      Hope this helps!
      --Chris
      Hi Chris,

      Thanks for the reply! I will implement as recommended and will update you soonest! Once I can get the DB some downtime

      Comment


      • #4
        Hi Chris,

        Just a few questions:

        1) If I were to increase the Maximum Capacity field from my 30 to 200, what would the impact be on my application server's memory requirements. Is there a formula for me to be able to calculate how much memory is required?

        2) On the Oracle side, what would be the SGA and cache impact from changing to 300 processes? Again is there a formula for me to be able to determine the memory requirements?

        Thanks for any information!

        Ian

        Comment


        • #5
          Ian,

          In response to your questions:

          1) I'm surprised that your maximum was set to 30 as 150 is usually the default value. On the OTM side, there is a negligible affect to this (possibly a few megabytes), but unfortunately there isn't a formula to help.

          2) I believe that the client processes aren't included in the SGA but rather the PGA memory allocation and that their memory impact is minimal (until used). I'm sure that there is a formula to determine the memory requirements, but I unfortunately haven't seen it. If there is a DBA out there who can respond - I'd greatly appreciate it!

          I can tell you that we've increased these settings on several OTM installations with minimal memory implications. The bulk of the memory usage will come from having more OTM processes run concurrently, due to the increase in DB connections available.

          Also, while searching for an answer to #2, I did come across a brief article on tuning Oracle on AIX. It's a bit basic, but still it may help you:

          Oracle AIX Tuning Optimization

          I hope this helps!

          --Chris

          Comment


          • #6
            Originally posted by chrisplough View Post
            Ian,

            In response to your questions:

            1) I'm surprised that your maximum was set to 30 as 150 is usually the default value. On the OTM side, there is a negligible affect to this (possibly a few megabytes), but unfortunately there isn't a formula to help.

            2) I believe that the client processes aren't included in the SGA but rather the PGA memory allocation and that their memory impact is minimal (until used). I'm sure that there is a formula to determine the memory requirements, but I unfortunately haven't seen it. If there is a DBA out there who can respond - I'd greatly appreciate it!

            I can tell you that we've increased these settings on several OTM installations with minimal memory implications. The bulk of the memory usage will come from having more OTM processes run concurrently, due to the increase in DB connections available.

            Also, while searching for an answer to #2, I did come across a brief article on tuning Oracle on AIX. It's a bit basic, but still it may help you:

            Oracle AIX Tuning Optimization

            I hope this helps!

            --Chris
            Hi Chris,

            Excellent information! Will bring this back to my DBA and Infrastructure team!

            Rep inbound!

            Thanks!
            Ian

            Comment

            Working...
            X