Announcement

Collapse
No announcement yet.

Using Modified XSL Without Restarting Tomcat

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Using Modified XSL Without Restarting Tomcat

    We are working on custom email notifications (for teder notifications). Since it is in develpment phase, we may need to modify XSL files quite often. Everytime we modify XSL files, we need to restart OTM.

    I believe there would be some property file in OTM which would make the server in DEBUG mode which help us working with modified XSLs without restarting OTM.

    Any help in this regard is highly appreciable.

    /Raghu Lakshman

  • #2
    Re: Using Modified XSL Without Restarting Tomcat

    glog.webserver.xsl.debug=true...it is located in the Branding Document. Don't expect all of the files will work with this however, I have seen some things still requiring a restart of the web tier.
    If my post was helpful please click on the Thanks! button

    MavenWire Hosting Admin
    15 years of OTM experience

    Comment


    • #3
      Re: Using Modified XSL Without Restarting Tomcat

      Because it doesn't work always, I always use another map to put the files in. Then change the path to the stylesheet.
      At least this works for screen lay outs.
      Best Regards,

      Bob Romijn

      Comment


      • #4
        Re: Using Modified XSL Without Restarting Tomcat

        Originally posted by nick.polites View Post
        glog.webserver.xsl.debug=true...it is located in the Branding Document. Don't expect all of the files will work with this however, I have seen some things still requiring a restart of the web tier.
        Thanks Nick. It indeed worked.

        Comment


        • #5
          Re: Using Modified XSL Without Restarting Tomcat

          Originally posted by nick.polites View Post
          glog.webserver.xsl.debug=true...it is located in the Branding Document. Don't expect all of the files will work with this however, I have seen some things still requiring a restart of the web tier.
          Hello All,

          I added the property glog.webserver.xsl.debug=true in the glog.properties file located in the <OTM_HOME>/otmapp/glog/config/ folder and restarted the server.

          Still I am not seeing simple changes like changing the branding xsl file from themesswanblue.xsl to themesswangreen.xsl.

          Does anybody have any idea what I might be doing wrong?

          Thanks,
          Shaf

          Comment

          Working...
          X