Announcement

Collapse
No announcement yet.

Issue with OTM and Tomcat

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Issue with OTM and Tomcat

    We patched our HP Linux servers. The OTM Application Server has not been accepting connections since. Our environment has four tiers, Database, Application, Web Server, and Reporting Server (OBIEE/FTI). Everything is separated out. The only errors I see in the log are listed below. Oracle Support has not been much help. We may have to back the patches out. I welcome any comments or recomendations.
    See my note:
    INFO | 2010/01/22 08:25:01 | INFO: Marking servlet Initialize as unavailable
    INFO | 2010/01/22 08:25:01 | Jan 22, 2010 8:25:01 AM org.apache.catalina.core.StandardContext loadOnStartup
    INFO | 2010/01/22 08:25:01 | SEVERE: Servlet /GC3 threw load() exception
    INFO | 2010/01/22 08:25:01 | javax.servlet.UnavailableException: The OTM Application Server is not available.

    Donald V.

  • #2
    Re: Issue with OTM and Tomcat

    We need to know what version of OTM and if you are using Weblogic or OAS. Can you attach your console.log file?
    If my post was helpful please click on the Thanks! button

    MavenWire Hosting Admin
    15 years of OTM experience

    Comment


    • #3
      Re: Issue with OTM and Tomcat

      Our problem turned out to be the Iptables. Our Linux Admin is new at this. I will include more information the next time I post.

      I appreciate your responsee

      Comment


      • #4
        Re: Issue with OTM and Tomcat

        Hi I am getting the same error of
        javax.servlet.UnavailableException: The OTM Application Server is not available.

        Attaching the log files can any one help me please
        installed the app in Windows 2008 and OTM Version is 631
        logs.zip
        B.S.Chakravarthy Yadav
        Product Design Head

        Comment


        • #5
          Re: Issue with OTM and Tomcat

          Originally posted by bscyadav View Post
          Hi I am getting the same error of
          javax.servlet.UnavailableException: The OTM Application Server is not available.

          Attaching the log files can any one help me please
          installed the app in Windows 2008 and OTM Version is 631
          [ATTACH]1338[/ATTACH]

          Do you have any firewalls between the app and web servers?


          I also see you are binding to the local port 127.0.0.1-8009 for Tomcat. You should be using a static IP address and not your loopback port.
          If my post was helpful please click on the Thanks! button

          MavenWire Hosting Admin
          15 years of OTM experience

          Comment


          • #6
            Re: Issue with OTM and Tomcat

            The way it was solved is that when i start the tomcat server I need to delay it in relation to webapp. Other wise it was showing OTM APP not available
            B.S.Chakravarthy Yadav
            Product Design Head

            Comment


            • #7
              OTM6.3.3 - OTM and TOMCAT Services Not Starting

              All OTM 6.3.3 components are installed on Single Node - Linux 5.x

              I am also getting the same issue... please help the steps to resovle th issues


              $OTM_HOME/logs/tomcat/console.log.0
              INFO | 2014/05/15 22:27:14 | [INFO ][memory ] [YC#10] 43.085-43.157: YC 1259335KB->562912KB (2097152KB), 0.073 s, sum of pauses 72.748 ms, longest pause 72.748 ms.
              INFO | 2014/05/15 22:27:17 | May 15, 2014 10:27:17 PM org.apache.catalina.core.ApplicationContext log
              INFO | 2014/05/15 22:27:17 | INFO: Marking servlet InitializeWebScalability as unavailable
              INFO | 2014/05/15 22:27:17 | May 15, 2014 10:27:17 PM org.apache.catalina.core.StandardContext loadOnStartup
              INFO | 2014/05/15 22:27:17 | SEVERE: Servlet /GC3 threw load() exception
              INFO | 2014/05/15 22:27:17 | javax.servlet.UnavailableException: The OTM Application Server is not available.
              INFO | 2014/05/15 22:27:17 | at glog.webserver.util.NTierServlet.init(NTierServlet .java:33)
              INFO | 2014/05/15 22:27:17 | at org.apache.catalina.core.StandardWrapper.initServl et(StandardWrapper.java:1280)
              INFO | 2014/05/15 22:27:17 | at org.apache.catalina.core.StandardWrapper.loadServl et(StandardWrapper.java:1193)
              INFO | 2014/05/15 22:27:17 | at org.apache.catalina.core.StandardWrapper.load(Stan dardWrapper.java:108
              INFO | 2014/05/15 22:27:17 | at org.apache.catalina.core.StandardContext.loadOnSta rtup(StandardContext.java:5176)
              INFO | 2014/05/15 22:27:17 | at org.apache.catalina.core.StandardContext.startInte rnal(StandardContext.java:5460)
              INFO | 2014/05/15 22:27:17 | at org.apache.catalina.util.LifecycleBase.start(Lifec ycleBase.java:150)
              INFO | 2014/05/15 22:27:17 | at org.apache.catalina.core.ContainerBase$StartChild. call(ContainerBase.java:1560)
              INFO | 2014/05/15 22:27:17 | at org.apache.catalina.core.ContainerBase$StartChild. call(ContainerBase.java:1549)
              INFO | 2014/05/15 22:27:17 | at java.util.concurrent.FutureTask$Sync.innerRun(Futu reTask.java:303)
              INFO | 2014/05/15 22:27:17 | at java.util.concurrent.FutureTask.run(FutureTask.jav a:139)
              INFO | 2014/05/15 22:27:17 | at java.util.concurrent.ThreadPoolExecutor$Worker.run Task(ThreadPoolExecutor.java:895)
              INFO | 2014/05/15 22:27:17 | at java.util.concurrent.ThreadPoolExecutor$Worker.run (ThreadPoolExecutor.java:919)
              INFO | 2014/05/15 22:27:17 | at java.lang.Thread.run(Thread.java:680)
              INFO | 2014/05/15 22:27:17 | May 15, 2014 10:27:17 PM org.apache.coyote.AbstractProtocol start
              INFO | 2014/05/15 22:27:17 | INFO: Starting ProtocolHandler ["http-bio-127.0.0.1-8009"]
              INFO | 2014/05/15 22:27:17 | May 15, 2014 10:27:17 PM org.apache.catalina.startup.Catalina start
              INFO | 2014/05/15 22:27:17 | INFO: Server startup in 44434 ms
              "console.log.0" 84L, 10938C
              ......
              $OTM_HOME/logs/weblogic/console.log.0
              values and defaults that correspond to the development mode specified in config.xml.>
              INFO | 2014/05/15 23:16:39 | <May 15, 2014 11:16:39 PM SGT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to STARTING>
              INFO | 2014/05/15 23:16:39 | <May 15, 2014 11:16:39 PM SGT> <Info> <WorkManager> <BEA-002900> <Initializing self-tuning thread pool>
              INFO | 2014/05/15 23:16:40 | <May 15, 2014 11:16:40 PM SGT> <Notice> <Log Management> <BEA-170019> <The server log file /u01/applotm/OTM6/logs/weblogic/weblogic.log is opened. All server side log events will be written to this file.>
              INFO | 2014/05/15 23:16:43 | GC3 realm initializing <-----------
              INFO | 2014/05/15 23:16:44 | cause.InvalidDataConnection
              INFO | 2014/05/15 23:16:44 |
              INFO | 2014/05/15 23:16:44 | at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)
              INFO | 2014/05/15 23:16:44 | at sun.reflect.NativeConstructorAccessorImpl.newInsta nce(NativeConstructorAccessorImpl.java:39)
              INFO | 2014/05/15 23:16:44 | at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(DelegatingConstructorAccessorImpl.java:27)
              INFO | 2014/05/15 23:16:44 | at java.lang.reflect.Constructor.newInstance(Construc tor.java:513)
              INFO | 2014/05/15 23:16:44 | at glog.util.exception.GLException.factory(GLExceptio n.java:460)
              INFO | 2014/05/15 23:16:44 | at glog.util.exception.GLException.factory(GLExceptio n.java:436)
              INFO | 2014/05/15 23:16:44 | at glog.util.exception.GLException.factory(GLExceptio n.java:432)
              INFO | 2014/05/15 23:16:44 | at glog.util.exception.GLException.factory(GLExceptio n.java:420)
              INFO | 2014/05/15 23:16:44 | at glog.util.jdbc.noserver.T2SharedConnection.checkDa taSource(T2SharedConnection.java:347)
              INFO | 2014/05/15 23:16:44 | at glog.util.jdbc.noserver.T2SharedConnection$Referen cedConnection.addRef(T2SharedConnection.java:464)
              INFO | 2014/05/15 23:16:44 | at glog.util.jdbc.noserver.T2SharedConnection$Referen cedConnection.addRef(T2SharedConnection.java:43
              INFO | 2014/05/15 23:16:44 | at glog.util.jdbc.noserver.T2SharedConnection.open(T2 SharedConnection.java:70)
              INFO | 2014/05/15 23:16:44 | at glog.database.security.dbrealm.RdbmsRealm.getKnown Groups(RdbmsRealm.java:1632)
              INFO | 2014/05/15 23:16:44 | at glog.database.security.dbrealm.RdbmsRealm.getKnown Groups(RdbmsRealm.java:166
              INFO | 2014/05/15 23:16:44 | at glog.database.security.dbrealm.CachingRealm.readKn ownGroups(CachingRealm.java:421)
              INFO | 2014/05/15 23:16:44 | at glog.database.security.dbrealm.CachingRealm.initCa ches(CachingRealm.java:191)
              INFO | 2014/05/15 23:16:44 | at glog.database.security.dbrealm.CachingRealm.<init> (CachingRealm.java:141)
              INFO | 2014/05/15 23:16:44 | at glog.database.security.dbrealm.CachingRealm.initia lize(CachingRealm.java:123)
              INFO | 2014/05/15 23:16:44 | at glog.util.j2ee.jaas.GC3AuthenticationProviderImpl. initialize(GC3AuthenticationProviderImpl.java:32)
              INFO | 2014/05/15 23:16:44 | at com.bea.common.security.internal.legacy.service.Se curityProviderImpl.init(SecurityProviderImpl.java: 60)
              INFO | 2014/05/15 23:16:44 | at com.bea.common.engine.internal.ServiceEngineImpl.f indOrStartService(ServiceEngineImpl.java:363)
              INFO | 2014/05/15 23:16:44 | at com.bea.common.engine.internal.ServiceEngineImpl.f indOrStartService(ServiceEngineImpl.java:315)
              INFO | 2014/05/15 23:16:44 | at com.bea.common.engine.internal.ServiceEngineImpl.l ookupService(ServiceEngineImpl.java:257)
              INFO | 2014/05/15 23:16:44 | at com.bea.common.engine.internal.ServicesImpl.getSer vice(ServicesImpl.java:72)
              INFO | 2014/05/15 23:16:44 | at weblogic.security.service.internal.WLSIdentityServ iceImpl.initialize(WLSIdentityServiceImpl.java:46)
              INFO | 2014/05/15 23:16:44 | at weblogic.security.service.CSSWLSDelegateImpl.initi alizeServiceEngine(CSSWLSDelegateImpl.java:299)
              INFO | 2014/05/15 23:16:44 | at weblogic.security.service.CSSWLSDelegateImpl.initi alize(CSSWLSDelegateImpl.java:220)
              INFO | 2014/05/15 23:16:44 | at weblogic.security.service.CommonSecurityServiceMan agerDelegateImpl.InitializeServiceEngine(CommonSec urityServiceManagerDelegateImpl.java:1789)
              INFO | 2014/05/15 23:16:44 | at weblogic.security.service.CommonSecurityServiceMan agerDelegateImpl.initializeRealm(CommonSecuritySer viceManagerDelegateImpl.java:443)
              INFO | 2014/05/15 23:16:44 | at weblogic.security.service.CommonSecurityServiceMan agerDelegateImpl.loadRealm(CommonSecurityServiceMa nagerDelegateImpl.java:841)
              INFO | 2014/05/15 23:16:44 | at weblogic.security.service.CommonSecurityServiceMan agerDelegateImpl.initializeRealms(CommonSecuritySe rviceManagerDelegateImpl.java:870)
              INFO | 2014/05/15 23:16:44 | at weblogic.security.service.CommonSecurityServiceMan agerDelegateImpl.initialize(CommonSecurityServiceM anagerDelegateImpl.java:1032)
              INFO | 2014/05/15 23:16:44 | at weblogic.security.service.SecurityServiceManager.i nitialize(SecurityServiceManager.java:873)
              INFO | 2014/05/15 23:16:44 | at weblogic.security.SecurityService.start(SecuritySe rvice.java:141)
              INFO | 2014/05/15 23:16:44 | at weblogic.t3.srvr.SubsystemRequest.run(SubsystemReq uest.java:64)
              INFO | 2014/05/15 23:16:44 | at weblogic.work.ExecuteThread.execute(ExecuteThread. java:256)
              INFO | 2014/05/15 23:16:44 | at weblogic.work.ExecuteThread.run(ExecuteThread.java :221)
              INFO | 2014/05/15 23:16:44 | Fatal Error: Realm Initialization failed!!
              INFO | 2014/05/15 23:16:44 | <May 15, 2014 11:16:44 PM SGT> <Notice> <WebLogicServer> <BEA-000388> <JVM called WLS shutdown hook. The server will force shutdown now>
              INFO | 2014/05/15 23:16:44 | <May 15, 2014 11:16:44 PM SGT> <Alert> <WebLogicServer> <BEA-000396> <Server shutdown has been requested by <WLS Kernel>>
              INFO | 2014/05/15 23:16:44 | <May 15, 2014 11:16:44 PM SGT> <Notice> <WebLogicServer> <BEA-000365> <Server state changed to FORCE_SHUTTING_DOWN>
              INFO | 2014/05/15 23:16:45 | Stopped Launched Process...
              Attached Files
              Last edited by dhanrajchilla; May 16, 2014, 05:32.

              Comment


              • #8
                Re: OTM6.3.3 - OTM and TOMCAT Services Not Starting

                appreciate your comments on the above issues... please help

                Comment


                • #9
                  Re: OTM6.3.3 - OTM and TOMCAT Services Not Starting

                  Hi,

                  As I have checked in your provided logs and found that, OTM application server is not able to connect with database

                  Please check your OTM Application server connection with OTM database server

                  Thank you


                  -Prasad-
                  Let's connect on LinkedIn
                  Mobile: +91 973 049 6886
                  E-mail: [email protected]

                  If my post was helpful, then click on the Like button

                  Comment

                  Working...
                  X