Announcement

Collapse
No announcement yet.

Which BPEL Process Manager for OTM 6.1?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Which BPEL Process Manager for OTM 6.1?

    I am attempting to design the architecture and eventual installation of OTM 6.1 for use with EBS 11.5.10.2. In spite of many years of experience with Oracle products, including E-Business Suite and RAC, I am finding this to be the most difficult architecture I have yet seen due to the random number of components involved and the lack of a clearly documented installation process. I realize that I am not the first to make this observation, but would still appreciate some feedback on the following question:

    Which BPEL installation type should be used with the following components?
    * OTM 6.1 (basic, no "Intelligence" options)
    * WebLogic 11g Release 1 (10.3.1)
    * E-Business Suite 11.5.10.2

    The reason for this question is that there are 4 options for BPEL installation, according to the OTN "Release Downloads for Oracle BPEL Process Manager" page at collateral
    1) BPEL Process Manager 11g (not certified with OTM 6.1, need 10.1.3.4 or 10.1.3.5)
    2) SOA Suite 10g
    3) BPEL Process Manager 10.1.3.1.0 Standalone for OC4J
    4) BPEL Process Manager 10.1.3.x Standalone for non-Oracle platforms (which includes Oracle BPEL Process Manager 10.1.3.3 for BEA WebLogic)

    In an effort to "keep it simple", I am thinking of using option 4 and installing and configuring BPEL to use WebLogic instead of installing the full SOA Suite with Oracle Application Server. All of the Fusion and SOA components are new to me, so I don't know enough about them to know if this is a realistic combination.

    I can't find any references on this site, Oracle Support, or via Google that indicate which of the BPEL installations will (or will not) work, and since this is my first OTM installation, I am hoping that someone who has already faced this dilemma can answer my question.

    Thanks for the help and for a great forum!
    Craig


  • #2
    Re: Which BPEL Process Manager for OTM 6.1?

    Craig,

    Before answering, I'm curious about whether you intend to use the Oracle pre-packaged integration flows for EBS and OTM, or whether you'll be developing custom flows.

    I ask because the version of BPEL depends on it and also, I don't believe that OTM v6.1 => EBS 11.5 is fully supported by those flows. I believe that OTM v6.1 and the pre-packaged flows are intended for EBS 12.x.

    If you don't intend to use the pre-packaged flows, then multiple versions of BPEL will work. For instance, one of our Hosting customers is utilizing OTM v6.1 and the latest 11g SOA Suite (based on WebLogic 11g).

    BTW - if it's any consolation, I found the EBS architecture pretty foreign after years of working with OTM. Being new (relatively) to the Oracle family has a lot to do with it

    --Chris

    Comment


    • #3
      Re: Which BPEL Process Manager for OTM 6.1?

      Hi Chris,

      Thanks for the quick reply!

      We plan to use the Oracle pre-packaged integration flows during the pilot and gap analysis, and will only create custom flows if needed. We are trying to keep this as simple as possible, meaning minimal components and customizations. However, I don't want to provide such a sparse implementation that we can't expand or customize it, either!

      Thanks for the input on the OTM v6.1 => EBS 11.5 support. I know that 6.0 is "supported" with 11.5.10.2 (from an earlier Service Request), but have only seen hints that 6.1 is supported with the "old" EBS version. Do the pre-packaged flows in 6.0 work with 11i, or do I need to drop back to 5.5, which I know works with 11i?

      My goal is to implement the latest versions of each component that will work with each other and EBS 11i, and it has been difficult without having experience with these components. I really appreciate your sharing of wisdom and lessons learned!

      Thanks,
      Craig

      Comment


      • #4
        Re: Which BPEL Process Manager for OTM 6.1?

        Craig,

        It may be worth openning a ticket to verify, but the latest info I have is that you're best using OTM v5.5 with EBS 11i and OTM v6.x with EBS 12.

        In which case, the v5.5 flows are based on the old version of SOA/BPEL (10.1.3.3, if memory serves).

        Currently for v6.1 we're utilizing mostly custom integration flows - but that's based on the requirements of our current projects.

        --Chris

        Comment


        • #5
          Re: Which BPEL Process Manager for OTM 6.1?

          Chris,
          I talked to Oracle Support, and they said that OTM 6.x works fine with EBS 11.5 (and is supported), and that using WebLogic with BPEL is a good solution for OTM 6.x. This means that my desired architecture SHOULD work.

          I'll let you know how this all turns out.

          Thanks again!
          Craig

          Comment


          • #6
            Re: Which BPEL Process Manager for OTM 6.1?

            Thanks for the info - please do keep us updated!

            --Chris

            Comment


            • #7
              Re: Which BPEL Process Manager for OTM 6.1?

              Chris, you mentioned that you had a client that was able to work with OTM 6.1 and SOA 11g? Do you happen to know how the external system was setup?

              Comment


              • #8
                Re: Which BPEL Process Manager for OTM 6.1?

                Yes - the integration was setup to use Integration Data Queues within the External System.

                --Chris

                Comment


                • #9
                  Re: Which BPEL Process Manager for OTM 6.1?

                  Can i ask whether this was a custom External System, or one of the ones needed to integrate with EBS?

                  Comment

                  Working...
                  X