No announcement yet.

[SOLVED] How To Import a Model?

This topic is closed.
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] How To Import a Model?


    As per online help, there should be one sample model that can be imported through blueprint domain. But i'm not able to do this following the given steps in online help, can anybody help?

    To import a model and associate domains with the BLUEPRINT domain, follow these steps.
    1. <LI class=kadov-p-CNumber>Log on to the BLUEPRINT.ADMIN domain.
      <LI class=kadov-p-CNumber>Import the sample model to the BLUEPRINT domain. This will make the BLUEPRINT domain look like the imported model.
      <LI class=kadov-p-CNumber>Customize the menus and screens in the BLUEPRINT domain so that it reflects your desired organization of OTM.
    2. Associate the BLUEPRINT domain with another domain in the system. After the domain is associated with BLUEPRINT and changes you make to BLUEPRINT will be immediately reflected in any associated domains. If you want to stop the association between the domain and BLUEPRINT then you must manually remove the OTM_ADMIN and OTM_PLANNER user roles from all aspects of the user access configuration.
    After you complete the preceding steps, all domains associated with BLUEPRINT will look and behave exactly like the BLUEPRINT domain.

    Really appreciate any clues on this.


  • #2
    Re: How To Import a Model?

    Got reasons, it's due to unsuccessful loading of public data. see below solution.

    The issue is caused by the following setup: The (OTM Environment setting script) was not run in the specified format
    The command should be run as . ./ from the Application server directory, <otm_install dir>/install.

    The setup causes the issue because the OTM environment was not set up correctly before t
    he dbpatch_55.sql was run.
    The dbpatch_55.sql also invokes the update_content process that uploads PUBLIC data into OTM. Part of this PUBLIC data are the refer
    ences to various OTM screens.
    Since the OTM environment was not set correctly, the Update_content failed to run and hence no screen information was loaded into
    the database.
    Hence, when the user tried to access the Order screens, they got a HTTP 404 error.

    Change the setup for running the file by running it as . ./

    The setup will do the following:
    1.The set up change will enable the successful uploading of PUBLIC data when the update_content script is run as part of the dbpatch_55.sql

    -- To implement the solution, please execute the following steps::
    1. Log on to the Application server
    2. Navigate to <Otm_install_directory>/install

    3. Run the following command as it is . ./ (please note that the script should be run as dot space dot slash
    Then change directory into, <otm_install_directory>/glog/oracle/script8.
    SQLPLUS into the database with the following command,
    sqlplus glogowner/glogowner@<OTM Database Connect String>
    Run the SQL, @dbpatch_55.sql
    Make sure that the DB Patch runs successfully. Verify the Update_content log shows that CSV files are uploaded succ
    Re-start the web and application servers.

    4. Retest the issue.


    • #3
      Re: How To Import a Model?

      Thank you for the information.

      We've been working a lot with models and the BLUEPRINT domain in order to speed up implementations for clients. While we've been successful in importing local models (like the included DOMESTIC TRUCKLOAD model) - we're still experiencing significant issues in trying to transfer this information from on OTM instance to another, using the remote server pull process.

      Has anyone used this in the past and are there any suggestions or lessons learned that you can share?