Announcement

Collapse
No announcement yet.

5.5RU6CU3 to 6.1 migration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • 5.5RU6CU3 to 6.1 migration

    I wish to migrate the database from OTM5.5Ru6CU3 to OTM 6.1. I have a 11g x64 bit OTM 6.1 installation.

    I have already patched OTM 6.1 to Ru4.

    I wish to clarify the steps required.

    Can I migrate doing a full export\import from 5.5CU6Ru3 db to OTM v6.1RU4 and then run the conversion steps outlined in the installation?

    I would think that would over write the 6.1 specific data I installed when I set up OTM 6.1.

    Thanks,

    Rick

  • #2
    Re: 5.5RU6CU3 to 6.1 migration

    Hi Rick,

    Yes. but if you're only on CU3 and not CU6 (not sure if when you said RU6CU3 it was a typo) then before you migrate to 6.1 you should apply CU6 to your 5.5 instance then run the export/import and follow the migration steps. Oracle recommends that you be on the last CU of the prior release and the latest point version of 6.1 before attempting the migration. You do not need to actually start your 5.5.6 environment just consider it to be a step in the migration process. The 6.1 migration scripts will transform the schema for you and will add 6.1 specific data via csv files on the 6.1 app server. Make sure your migration logs are free of errors (or that the errors are known and considered safe) before continuing on to the next step in the process.

    Some shops find the export/import process to be too time consuming (depending on the size of the database). Also there is some risk in upgrading both the app and the DB at the same time as you may find that you have performance issues and isolating the source of the problem may be more difficult (since both the app and DB have changed versions, not to mention O/S and WebLogic). An alternative method would be to first upgrade 5.5 to CU6 (At least CU5 is required for 11g). Then do an in place database upgrade to 11g (Release 2 is preferred btw) and have your DBA tune the DB for performance and run with it for a period of time. Then at a later time upgrade to 6.1. The downside of this approach is the testing required for both the 5.5 CU6 and 6.1 upgrades but depending on your circumstances it may pay dividends. It will allow you to break up the upgrade which may be important to you if you have a large database and a limited window to migrate. It will also reduce the footprint of what is actually changing making isolating and resolving performance issues easier.

    Thanks,
    Alan
    Last edited by acuartero; June 1, 2011, 03:21.

    Comment


    • #3
      Re: 5.5RU6CU3 to 6.1 migration

      Rick,

      If you are going to do an export/import be sure to use datapump as it is a bit faster compared to the old imp and exp.

      If you have a DBA on site, they should be able to just take the datafiles, modify the control files and do an in place upgrade to 11.2.0.2. This is what we did for one of our customers that was on 5.5 going to 6.1.

      There is a bug in 11.2.0.2 which causes OTM not to startup if you have FTI. There is also a bug in 11.2.0.1 which causes indexes to become corrupted if there are too many deadlocks so keep that in mind with the versions. I think Oracle has fixed the 11.2.0.2 in the latest sub update 11.2.0.2.2 but it is bug number 11055942.

      As Alan mentions, you are going to have to patch to 5.5 CU6 then make the hop to 6.1.

      What Oracle asks you do is the following:

      Upgrade 5.5 CU3 RU6 to 5.5 CU6 then apply RU3 but don't update the database until RU3 has been applied first. This allows for any fixes to upgrade bugs that may have been in the CU6 base code. Then upgrade the database structure to 5.5 CU6, then to 5.5 CU6 RU3. After this point you would being the 6.1 upgrade. You already mention you have the base code to 6.1.4 so after you finish upgrading to 6.1 you would then apply the 6.1.4 update to the database.


      Nick
      If my post was helpful please click on the Thanks! button

      MavenWire Hosting Admin
      15 years of OTM experience

      Comment


      • #4
        Re: 5.5RU6CU3 to 6.1 migration

        Alan/Nick,

        Ok, it looks like I duplicated some steps. I did the install of OTM 6.1 following the administration guide for a fresh install, so the database has already been loaded with the Public data, tablespaces and users and I have installed OTM 6.1.4 patch to the app,db and web servers.

        Once the full import/export happens I will have to upgrade the database again to the 6.1 version.

        You are correct, out 5.5 installation is at CU6RU3 on 11g. That was upgraded a couple months ago.

        Once the OTM 5.5 database is migrated I will run the conversion steps outlined in the administration guide and then rerun the 6.1.4 db patch again.

        Rick

        Comment


        • #5
          Re: 5.5RU6CU3 to 6.1 migration

          Rick,

          If you already loaded public data you will need to drop the users to get a clean import from the 5.5 export.

          Nick
          If my post was helpful please click on the Thanks! button

          MavenWire Hosting Admin
          15 years of OTM experience

          Comment


          • #6
            Re: 5.5RU6CU3 to 6.1 migration

            Nick,

            When you say drop users do you mean drop DBA.ADMIN, GUEST.ADMIN or GLOGOWNER, REPORTOWNER, ETC?

            Rick

            Comment


            • #7
              Re: 5.5RU6CU3 to 6.1 migration

              Nope this would be run as sys:


              drop user GLOGDBA cascade;
              drop user GLOGOWNER cascade;
              drop user GLOGLOAD cascade;
              drop user REPORTOWNER cascade;
              drop user GLOBALREPORTUSER cascade;
              drop user ARCHIVE cascade;
              drop user GLOGDEV cascade;
              drop user HDOWNER cascade;

              You would then run @create_glog_users afterwhich you would import the exported 5.5 database.
              If my post was helpful please click on the Thanks! button

              MavenWire Hosting Admin
              15 years of OTM experience

              Comment


              • #8
                Re: 5.5RU6CU3 to 6.1 migration

                Rick,

                btw, I see that 6.1.5 was just announced.

                Oracle Transportation Management and Oracle Global Trade Management Version 6.1.5 Are Now Available [ID 1325477.1]

                "Oracle Transportation Management and Oracle Global Trade Management 6.1.5 are available for download from My Oracle Support as of May 27th, 2011."

                Thanks,
                Alan

                Comment


                • #9
                  Re: 5.5RU6CU3 to 6.1 migration

                  Alan,

                  Thanks, I will probably upgrade to 6.1.5 after I get the db migration finished.

                  Rick

                  Comment

                  Working...
                  X