Announcement

Collapse
No announcement yet.

Name space issue while using IntXMLService in OTM 6.0 while integrating with Tibco

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Name space issue while using IntXMLService in OTM 6.0 while integrating with Tibco

    Hi,

    I am trying to send an Inbound Transmission to IntXML service(OTM 6.0 App) using Tibco, but facing an issue with the name space. I have copied the IntXMLservice.wsdl and GLogXml.xsd from OTM 6.0 front end.

    My input Trnamission element look like this
    <ns0:Transmission xmlns:ns0 = "http://xmlns.oracle.com/apps/otm">
    <ns0:TransmissionHeader>... </ns0:Transmission>

    OTM sends back an TransmissionAck with <StackTrace>org.xml.sax.SAXParseException: The prefix "ns0" for element "ns0:Transmission" is not bound.

    Any suggestions on how to get rid of this ns0, would be of great help.

    The same input xml worked fine in OTM 5.5.

    Regards
    Chathur

  • #2
    Re: Name space issue while using IntXMLService in OTM 6.0 while integrating with Tibc

    Try to set
    glog.integration.enableParserInServlets=true
    Property to enable parsing XML received in WMServlet to remove/filter namespace prefixes.
    --
    Joseph Liang
    MavenWire APAC
    http://www.mavenwire.com/

    Comment


    • #3
      Re: Name space issue while using IntXMLService in OTM 6.0 while integrating with Tibc

      Hi Joseph,

      Thank you for the reply, this is useful when we hit WMServlet.
      I am hitting the INTXMlService, which is on the OTM app server, so there is no intervention of servlets(WMServlet). Is there any other property that can be set or any other workaround.

      Many Thanks
      Chathur

      Comment


      • #4
        Re: Name space issue while using IntXMLService in OTM 6.0 while integrating with Tibc

        Hi Chathur,

        I have exactly the same issue when contacting IntXmlService from Oracle's Fusion 11g integration platform. First, thanks for pointing out your issue - I almost went crazy on this one, searching everywhere for the error before assuming OTM's fault.

        Actually, the exact same error even shows up when you invove IntXmlService on its internally generated test page, i.e. http://yourhost.org:8888/GC3Services/IntXmlService/webservice.


        In case you find anything as how to fix it, please keep us updated here; I will do the same.

        Thanks,
        Sven
        Last edited by svenhaul; January 20, 2010, 15:07. Reason: URL not showing completely, but seems to be unfixable :-(

        Comment


        • #5
          Re: Name space issue while using IntXMLService in OTM 6.0 while integrating with Tibc

          I have got one workaround so far, sadly not in OTM: On the sending side, just remove the namespace prefix completely, so the XML looks like this:

          Code:
          <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/">
              <soap:Body xmlns="http://xmlns.oracle.com/apps/otm">
                  <Transmission>
                      <TransmissionHeader>
                          <Version></Version>
                          <TransmissionType></TransmissionType>
                          <QueryReplyFormat></QueryReplyFormat>
                          <StagingInfo>
          ...
          Now I need to find a way in my sending application how to tweak the XML accordingly, or another workaround...

          Comment


          • #6
            Re: Name space issue while using IntXMLService in OTM 6.0 while integrating with Tibc

            Short update:
            After comparing a log of the transmission on the wire with the OTM ad-hoc logs giving also the entire XML, it becomes clear that OTM is actively removing the otm namespace, but only the otm namespace.

            On the wire:
            <env:Envelope xmlns:env="http://schemas.xmlsoap.org/soap/envelope/"
            xmlns:wsa="http://www.w3.org/2005/08/addressing">...<env:Body>
            <otm:Transmission
            ...
            xmlnstm="http://xmlns.oracle.com/apps/otm"
            xmlns:hwf="http://xmlns.oracle.com/bpel/workflow/xpath"
            ...
            >

            OTM Log:
            2010-01-26 17:10:49.563 0 Debug SOAPService IntXmlService - process - source xml:
            <?xml version="1.0" encoding="UTF-8"?>
            <otm:Transmission xmlns:bpws="http://schemas.xmlsoap.org/ws/2003/03/business-process/" ... xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">

            I still have to find out which part of OTM is doing this, and if it can be prevented.
            Last edited by svenhaul; January 28, 2010, 15:48. Reason: got rid of annoying smiley showing up instead of namespace prefix

            Comment


            • #7
              Re: Name space issue while using IntXMLService in OTM 6.0 while integrating with Tibc

              Hi Sven,

              I got a work around within Tibco, removing the namespace before hitting the OTM.

              Thank you for the update.

              Regards
              Chathur

              Comment


              • #8
                Re: Name space issue while using IntXMLService in OTM 6.0 while integrating with Tibc

                I'm seeing the same problem. I'm sure I had a simple test working a few months ago, but now it's failing with the error that "ns1 is not bound". My SOAP message is shown below (id's redacted). OTM says ns1 is unbound in ns1:Transmission. I'm using the Python ZSI tools. I've stepped deeply into the logic for constructing the XML. The namespace logic is baked in, and I don't see how to get it to omit the ns1: prefix, since the WSDL explicitly puts Transmission into the http://xmlns.oracle.com/apps/otm namespace. What SOAP stacks are being used successfully with the IntXmlService? Are there any settings/configuration that's required to get them to work? Any help? Thanks.

                <SOAP-ENV:Envelope xmlns:SOAP-ENC="http://schemas.xmlsoap.org/soap/encoding/"
                xmlns:SOAP-ENV="http://schemas.xmlsoap.org/soap/envelope/"
                xmlns:ZSI="ZOLERA.COM" xmlns:xsd="XML Schema"
                xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <SOAP-ENV:Header></SOAP-ENV:Header>
                <SOAP-ENV:Body xmlns:ns1="http://xmlns.oracle.com/apps/otm">
                <ns1:Transmission>
                <ns1:TransmissionHeader>
                <ns1:UserName xsi:type="xsd:string">xxxxxx</ns1:UserName>
                <ns1:Password xsi:type="xsd:string">yyyyyy</ns1:Password>
                </ns1:TransmissionHeader>
                <ns1:TransmissionBody>
                <ns1:GLogXMLElement>
                <ns1:TransactionHeader></ns1:TransactionHeader>
                <ns1:TransOrder>
                <ns1:TransOrderHeader>
                <ns1:TransOrderGid>
                <ns1:Gid>
                <ns1omainName xsi:type="xsd:string">zzzzzz</ns1omainName>
                <ns1:Xid xsi:type="xsd:string">aaaaa</ns1:Xid>
                </ns1:Gid>
                </ns1:TransOrderGid>
                <ns1:TransactionCode xsi:type="xsd:string">I</ns1:TransactionCode>
                </ns1:TransOrderHeader>
                </ns1:TransOrder>
                </ns1:GLogXMLElement>
                </ns1:TransmissionBody>
                </ns1:Transmission>
                </SOAP-ENV:Body>
                </SOAP-ENV:Envelope>

                Comment


                • #9
                  Re: Name space issue while using IntXMLService in OTM 6.0 while integrating with Tibc

                  Hi,

                  I dont think there is any configuration.

                  1) Try placing the namse space in Transmission element.
                  ex. <SOAP-ENV:Body xmlns:ns1="http://xmlns.oracle.com/apps/otm">
                  <ns1:Transmission xmlns:ns1="http://xmlns.oracle.com/apps/otm">

                  2) If you can remove the ns1 completely in the inbound xml, that would be best.

                  Regards
                  Chathurvedi

                  Comment

                  Working...
                  X