Announcement

Collapse
No announcement yet.

OutBound from OTM to a WebService which Authenticates the User

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • OutBound from OTM to a WebService which Authenticates the User

    Hi All

    I need to send Outbound requests to a Webservice which authenticates the user sending it.
    I have configured the Webservice details in OTM, and send transmissions via external system.
    In the Webservice configuration I have provided the User Name and password. Business Process Automation > Communication Management > Web Services in Web Service Endpoints section.
    1) I am able to see the outbound Request hitting the Webservice, but authentication is failing.
    2) I checked the Transmisison in Transmission Manager of OTM, the transmission fails with 401 forbidden error(basically not authenticated at the other end).

    I am not sure if OTM sends the user id and password for authentication.

    We have two places to configure the username and passwords for authentication
    1) external system
    2) Webservice

    I tried setting at both the places but no positive result

    Did any one try to send outbound requests to External systems(Webservices), which require authentication.

    Any pointers towards resolving the issue wouldbe of great help.

    Regards
    Chathur

  • #2
    Re: OutBound from OTM to a WebService which Authenticates the User

    Hi All,

    got more info on HTTP Authentication.

    1) Outbound from OTM - Basic auth works when the external system is configured with HTTP. Basic Auth doesnt work when the external system is configured with Webservice.

    2) Inbound to OTM - Basic Auth works when sent via HTTP(ex to WMServlet). Basic Auth doesnt work when we call the Webservices(ex.IntXmlService).

    This is a bug in OTM,Bug# 9469321

    Regards
    Chathur

    Comment

    Working...
    X