Announcement

Collapse
No announcement yet.

EBS R12 to OTM integration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • EBS R12 to OTM integration

    Hi,
    We are on Oracle R12 and OTM 5.5. We have made all the setups changes and deployed the BPEL processes.
    We are testing the flow by running the Carrier Synchronization program from EBS. The program errors out. The log file shows an 'Unexpected Error' after the endpoint is getting called. The end point is calling the WshSendRefDataStlToOtm process. I was just wondering whether this is a wrong setup issue or whether we have missed something altogether.
    Has anybody done this integration and faced similar issues?
    Pl let me know.
    Regards,
    Ashwin

  • #2
    Re: EBS R12 to OTM integration

    Hi,

    My issue is similar to the one raised by Ashwin. View log files in EBS displayed below

    Entering SyncRefDataToOtm.runProgram
    Entering SyncRefDataToOtm.initVariables
    paramName is CARRIER_NAME_LOW
    paramValue is ADL Trucking
    paramName is CARRIER_NAME_HIGH
    paramValue is ADL Trucking
    paramName is LAST_UPDATE_DATE_LOW
    paramValue is
    paramName is LAST_UPDATE_DATE_HIGH
    paramValue is
    Exiting SyncRefDataToOtm.initVariables
    Entering SyncRefDataToOtm.initSecurityInfo
    Connection object [email protected]
    Exiting SyncRefDataToOtm.initSecurityInfo
    Entering SyncRefDataToOtm.validateProfiles
    Entering SyncRefDataToOtm.isOtmInstalled
    Connection object [email protected]
    Exiting SyncRefDataToOtm.isOtmInstalled
    domain Name is GUEST
    country code is USA
    Exiting SyncRefDataToOtm.validateProfiles
    Entering SyncRefDataToOtm.queryAndSendEntities
    entity Type is CARRIER
    carrierNameLow ADL Trucking
    carrierNameHigh ADL Trucking
    lastUpdateDateLow
    lastUpdateDateHigh null
    BPEL Domain is default
    query String is SELECT HPS.PARTY_SITE_ID, HPS.PARTY_ID, HPS.LOCATION_ID FROM WSH_CARRIERS_V WC, HZ_PARTY_SITES HPS WHERE HPS.PARTY_ID = WC.CARRIER_ID AND WC.ACTIVE = 'A' AND WC.CARRIER_NAME BETWEEN :1 AND :2 AND ( ( (:3 is null or WC.LAST_UPDATE_DATE >= to_date(:4,'YYYY/MM/DD HH24:MI:SS')) AND (:5 is null or WC.LAST_UPDATE_DATE <= to_date(:6,'YYYY/MM/DD HH24:MI:SS') )) OR ( (:7 is null or HPS.LAST_UPDATE_DATE >= to_date(:8,'YYYY/MM/DD HH24:MI:SS')) AND (:9 is null or HPS.LAST_UPDATE_DATE <= to_date(:10,'YYYY/MM/DD HH24:MI:SS')))) ORDER BY WC.CARRIER_ID
    l_dateLow is null
    l_dateHigh is null
    endPoint is http://rstn-lin15.us.oracle.com:7777...efDataStlToOtm
    curCarrSiteId is 6718
    curCarrierId is 12516
    curLocationId is 10896
    prevCarrierId is 0
    elementsCount is 0
    totCarrCount is 0
    totCarrSiteCount is 0
    Calling SendDocument outside the loop
    Entering SyncRefDataToOtm.sendDocument
    xml is <input xmlns="http://xmlns.oracle.com/apps/wsh/outbound/ref/WshSendRefDataStlToOtm"><entityType xmlns="http://xmlns.oracle.com/apps/wsh/outbound/util/WshOtmGlobalOutbound">CARRIER</entityType><entityIdList xmlns="http://xmlns.oracle.com/apps/wsh/outbound/util/WshOtmGlobalOutbound"><entityId>6718</entityId></entityIdList><parentIdList xmlns="http://xmlns.oracle.com/apps/wsh/outbound/util/WshOtmGlobalOutbound"><entityId>12516</entityId></parentIdList><securityContext xmlns="http://xmlns.oracle.com/apps/wsh/outbound/util/WshOtmGlobalOutbound"><ticket>EE096E68BF8C91AAD590 99E10F7DDE53</ticket><proxyServer /><proxyPort /><dbConn /><opCode>refOpCode</opCode><argKey>refArgKey</argKey></securityContext><appsContext xmlns="http://xmlns.oracle.com/apps/wsh/outbound/util/WshOtmGlobalOutbound"><userId /><respId /><respAppId /></appsContext></input>
    endPoint is http://rstn-lin15.us.oracle.com:7777...efDataStlToOtm
    Unexpected Error Occured
    Exiting SyncRefDataToOtm.sendDocument
    Total number of loops = 1
    Total number of Warnings = 1
    Exiting SyncRefDataToOtm.queryAndSendEntities
    Completion Status false
    Exiting SyncRefDataToOtm.runProgram

    Comment


    • #3
      Re: EBS R12 to OTM integration

      Just to verify, is the following link correct for your Oracle BPEL instance?

      http://rstn-lin15.us.oracle.com:7777/orabpel/default/WshSendRefDataStlToOtm

      --Chris

      Comment


      • #4
        Re: EBS R12 to OTM integration

        BPEL Instance URL : http://rstn-lin15.us.oracle.com:7777...ault/index.jsp

        Comment


        • #5
          Re: EBS R12 to OTM integration

          In that case, the logs aren't giving enough information to effectively troubleshoot. All of the relevant error information is below:
          Code:
          endPoint is http://rstn-lin15.us.oracle.com:7777...efDataStlToOtm
          Unexpected Error Occured
          Exiting SyncRefDataToOtm.sendDocument
          This could be a lot of things, including that the BPEL flow WshSendRefDataStlToOtm is not deployed onto your server, or is somehow not able to connect back to the EBS DB. I'd recommend investigating through the BPEL Console and analyzing the debug flow chart for this failed integration flow, to see exactly in which point in the flow failed and to see if it gives a more specific error message.

          After that, you can post more details here and we'll try to help. I'd also recommend opening an issue with your internal Oracle support resources -- that way you have multiple paths open in order to get this resolved quickly.

          --Chris

          Comment


          • #6
            Re: EBS R12 to OTM integration

            Hi Chris,

            Attached ppt provide you information on the failed flow and specific error message. I opened an Internal SR and yet to find a solution.

            Regards
            Ram
            Attached Files
            Last edited by RAMKUMAR768; April 22, 2008, 10:20.

            Comment


            • #7
              Re: EBS R12 to OTM integration

              Ram,

              The key error is on slide 11:

              java.net.UnknownHostException: otm-connor-gc3-55-wl.us.oracle.com: otm-connor-gc3-55-wl.us.oracle.com
              This error indicates that something on your BPEL server is not setup correctly (perhaps the GLogXML.xsd file - or the OTM hostname specified when running the ant process to deploy the BPEL jars? Basically, your BPEL server is trying to connect to one of Oracle's QA OTM servers, rather than the one you guys have installed. (I should know - I helped setup otm-connor-gc3-55-wl.us.oracle.com before leaving G-Log/Oracle a couple years ago.)

              I'd go back through your BPEL Jar deployment process and ensure everything was completed correclty.

              --Chris

              Comment

              Working...
              X