Announcement

Collapse
No announcement yet.

[SOLVED] WebLogic Error: <BEA-000402> maximum of number of socket reader thread

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] WebLogic Error: <BEA-000402> maximum of number of socket reader thread

    A client was recently performing some high-load Web UI testing on a new OTM v5.5 instance and continually received the following error:

    Code:
    ####<Apr 20, 2007 11:42:09 AM EDT> <Warning> <Socket> <otm.company.com> <gc3-otm> <ListenThread.Default> <<WLS Kernel>> <>
    <BEA-000402> <There are: 9 active sockets, but the maximum number of socket reader threads allowed by the configuration is: 8. You may want to alter your configuration.>
    Changing the Execute threads for a WebLogic instance is commonplace once OTM is pushed in high-performance load testing, however this was a new error that we hadn't seen before. In the end, we tracked this down to a specific parameter in the WebLogic config.xml.template file that specifies the percentage of Execute Threads set aside as Socket Reader Threads.

    So we edited the config file and added the following parameter:
    Code:
    ThreadPoolPercentSocketReaders="50"
    The source for this info was the following document:Hope this helps!

    Thanks!
    --Chris

  • #2
    Re: [SOLVED] WebLogic Error: &amp;lt;BEA-000402&amp;gt; maximum of number of socket reader th

    As a note, this issue has resurfaced. In as an attempted solution, we've added the following parameter to the java startup parameters in the weblogic.conf file ($OTM_HOME/weblogic/config/gc3domain/weblogic.conf):
    Code:
    -Dweblogic.PosixSocketReaders=9
    So far, it looks promising, but we'll only know for sure in time.

    Thanks!
    --Chris

    Comment


    • #3
      Re: [SOLVED] WebLogic Error: &amp;lt;BEA-000402&amp;gt; maximum of number of socket reader th

      As a quick update the "-Dweblogic.PosixSocketReaders=9" setting has not resolved the issue.

      This currently appears to be an issue with WebLogic that may be a software bug. I'll update when I know more.

      --Chris

      Comment


      • #4
        Re: [SOLVED] WebLogic Error: &amp;lt;BEA-000402&amp;gt; maximum of number of socket reader th

        This issue has finally been resolved (thanks Shelley), by changing the ThreadPoolPercentSocketReaders parameter in the config.xml.template file to "75".
        Code:
         <Server IIOPEnabled="false" 
            JDBCLogFileName="/opt/otm55/logs/weblogic/jdbc.log" 
            JDBCLoggingEnabled="false" ListenAddress="x.x.x.x" 
            ListenPort="7001" Name="gc3-server" NativeIOEnabled="true" 
            ServerVersion="8.1.4.0" TunnelingEnabled="true" 
            StdoutSeverityLevel="16" ThreadPoolPercentSocketReaders="75">
        --Chris

        Comment

        Working...
        X