Hi all,

We need to generate multi-language HTML reports on OTM. However, we have never been successful in doing so. After countless hours of investigation we found out the following interesting bits:

Has anyone been able to display multi-language reports in HTML on OTM?

1.] The charset in the output .HTM file's <meta> tag is being set to ISO-8859-1

This setting of charset to ISO-8859-1 (supports Latin and West European chars) have affected the rendition of Japanese chars by the browser (IE). The appropriate setting for the charset should be UTF-8 as it will display the Japanese chars correctly.

We found that this setting of charset to ISO-8859-1 is being made in the function BUILD_HTML_HEADER which is part of the "report_library.pll" (OTM issued library) that we are using for all OTM reports. Unfortunately, we don't have the source codes of the function.

We tried commenting the portion where the setting is being made and replace it with the hardcoding of the meta tags having charset UTF-8 in the report escapes properties (Before Report Value). This workaround seem to work as the .HTM file that is created already have the correct charset=UTF-8. Moreover, the Japanese chars are now appearing correctly when you open up the .HTM in IE or run the "rwservlet" from report server.

Thus, the issue is no longer in report server as everything works fine at that level provided that we change the charset to UTF-8 (it should for we already set the NLS_LANG to AMERICAN_AMERICA.UTF. The function BUILD_HTML_HEADER may need to be reviewed / rectified if needed to return the correct encoding.

2.] .HTM file having the correct encoding still appear as garbage chars in TMS

After making the adjustments mentioned in [1] and confirmed that everything works fine at the report server level, we tried launching the report in HTML view from TMS. However, the outcome is still the same - all Japanese chars still being displayed as garbages.

This one is obviously a problem in TMS already as the .HTM file being produced in the report server is already okay.

At least, we already confirmed that there's nothing wrong with our report server. It's the rendition at the TMS that is having some issues which they'll need to investigate.
Attached Files