Announcement

Collapse
No announcement yet.

[SOLVED] Multiple instances of runnign report !!!

Collapse
This topic is closed.
X
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • [SOLVED] Multiple instances of runnign report !!!

    Dear all,
    I am facing a very strange issue with some of the reports in OTM. Couple of reports when run in OTM create multiple instances of its own.

    Observations :
    -> All the duplicate instances have the same start time in Oracle Enterprise manager (OEM), though they are created after a time gap
    -> If one of the instance is stopped by the action in OEM, this halts all other instances of the same report
    ->Once the report is fully executed,it creates same number of output as of its instances.
    -> Usually happen with reports which take long time to run.
    -> Same copy of the report do not create the problem in other Envt( Test)
    -> No of duplicate instance vary from 5 - 15

    has anyone ever faced this type of issue? i Couldn't find the code which may be causing this issue in report,may be some properties of the evnt are causing this?? but if so it should happen for all the reports. Any suggestion which can solve this issue.
    Appreciate your response.

    Regards
    Geetika Dua
    Regards
    Geetika

    -----------------------------------------------------------
    If my post was useful please click Thanks!
    -----------------------------------------------------------

  • #2
    Re: Multiple instances of runnign report !!!

    I think you have hit the scalability feature built into reports. If the report instance name is the same on your dev/test/production it will use any of them to run the report. I never found a way to disable this feature so I just use names like Reports_Prod, Reports_Test, Reports_Dev so they are not unique.
    If my post was helpful please click on the Thanks! button

    MavenWire Hosting Admin
    15 years of OTM experience

    Comment


    • #3
      Re: Multiple instances of runnign report !!!

      Hello Nick,

      I checked the names of the test and prod server and they are different, could you please help. Now a days we are observing this issue with more reports.

      Regards
      Geetika Dua
      Regards
      Geetika

      -----------------------------------------------------------
      If my post was useful please click Thanks!
      -----------------------------------------------------------

      Comment


      • #4
        Re: Multiple instances of runnign report !!!

        Geetika,

        Sorry that's all I have seen in the past with this type of issue. I would have to take a look at the environment to troubleshoot it so you are best to log a metalink SR and have the OTM group take a look.

        Nick
        If my post was helpful please click on the Thanks! button

        MavenWire Hosting Admin
        15 years of OTM experience

        Comment

        Working...
        X