Announcement

Collapse
No announcement yet.

UOM_Loader_UOM_Class_Not_Found (strUOMType=EACH)

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • UOM_Loader_UOM_Class_Not_Found (strUOMType=EACH)

    Running in my Development environment for a couple of months, I am now receiving this error. I am able to login and the developers have not complained, but I would like to find out why. Just point me in the right direction and I can delve into it further. Or just tell me this is not something unseen before
    Thanks,
    Rick

    INFO | 2011/04/14 08:46:03 | cause.UOM_Loader_UOM_Class_Not_Found (strUOMType=EACH)
    INFO | 2011/04/14 08:46:03 |
    INFO | 2011/04/14 08:46:03 | at sun.reflect.NativeConstructorAccessorImpl.newInsta nce0(Native Method)
    INFO | 2011/04/14 08:46:03 | at sun.reflect.NativeConstructorAccessorImpl.newInsta nce(NativeConstructorAccessorImpl.java:39)
    INFO | 2011/04/14 08:46:03 | at sun.reflect.DelegatingConstructorAccessorImpl.newI nstance(DelegatingConstructorAccessorImpl.java:27)
    INFO | 2011/04/14 08:46:03 | at java.lang.reflect.Constructor.newInstance(Construc tor.java:513)
    INFO | 2011/04/14 08:46:03 | at glog.util.exception.GLException.factory(GLExceptio n.java:435)

  • #2
    This error is caused by an invalid UOM type value (EACH) in the UOM table. These are hard coded and there is only a selected list you can chose from which is

    AREA CURRENCY DENSITY DISTANCE DURATION LENGTH QUANTITY SPEED TEMPERATURE VOLUME WEIGHT

    In one of my customer instances which is on 6.3.3 AREA is not coded so not sure when that was added. Once those records are corrected with a valid type it should resolve the error.
    If my post was helpful please click on the Thanks! button

    MavenWire Hosting Admin
    15 years of OTM experience

    Comment

    Working...
    X